Combine install Ubuntu 9.10

by bose on July 23, 2010

Message below copied from here for my reference: Sourceforge forum

Looking at the installation problems that some of the Debian packages for Perl modules required that I have made available in the package repository had very strict dependencies on the perl-api. The two packages I had problems with are:

Text::Ngram and Text::ExtractWords.

Trying on freshly installed Ubuntu 9.10 I came up with the following sequence of commands that managed to install Combine. But be warned : A LOT OF other packages gets installed doing it this way!

sudo apt-get install devscripts dh-make-perl
cpan2deb Text::Ngram
sudo dpkg -i ../libtext-ngram-perl_0.11-1_i386.deb
cpan2deb Tex::ExtractWords
sudo dpkg -i ../libtext-extractwords-perl_0.08-1_i386.deb
sudo apt-get install combine

(Your .deb file-names may vary…)
This procedure might help you get Combine installed on your specific machine with your version of Perl.

Previous post:

Next post: